Snmp…up an running properly

After leaving Zenoss alone for a few days due to work and other reasons i started at it again early this week. My initial problem was that I could not walk my 2 linux boxes (both ubuntu) I was able to walk my window machines but not nix.

Maybe i may need to be a little clearer… I was able to walk the nix machine but only locally. After pulling the little hair i do have i ran:

netstat -an| grep 161

If  you do just netstat -an alone you’ll get a fullscreen of information

What i saw was:

 udp        0      0 127.0.0.1:161             0.0.0.0:*

THAT was/is the damn problem…. snmp was only listening to loopback. On a redhat based system it listens to everythning be default, why Ubuntu wanted to be different/special I have no clue. I had to edit /etc/default/snmpd and change

SNMPDOPTS=’-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid ‘127.0.0.1’

to

SNMPDOPTS=’-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid -a’

Restart snmpd and everything was good to go.. 😀 Every now and then I keep  being reminded that with linux READING is FUNDAMENTAL!!! 😀

Advertisements

3 Responses to “Snmp…up an running properly”

  1. thats for net-snmp? /etc/default/snmpd?

    damn ubuntu keep the files in one place.

  2. yep… that same one.

  3. I have no idea what is being said in this post -_- but eeer…umm…like the new theme ^-^

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: