Archive for March, 2010

VLC 1.0.5 via source in Lenny

Posted in General with tags , , on Sunday, March 14, 2010 by Yatta

I’ve installed Lenny on Bertha (HP XW4200) to basically be my multimedia pc…. having most of my saved tvshows, anime and maybe PVR (not sure yet)

I’ve wanted to add to this blog for sometime… but to he honest just been to rass lazy to do a writeup.

Anyway let’s get going with the reason for this post. VLC has always been a simple media player 0.8 is SIMPLE!!!! It was killing me.. i missed my vlc goldeneye!

1. I removed all aspects of vlc

apt-get –purge remove vlc

2. Since i’m going to install via source i need build-essentials

apt-get install build-essential

3. Now i tried to satisfy all the development dependencies

apt-get install libqt4-dev libpostproc-dev libavformat-dev libavcodec-dev libavutil-dev libmad0-dev liba52-0.7.4-dev libhal-dev libdbus-1-dev libfribidi-dev libgcrypt11-dev

I also had to install libx11-dev libxpm-dev x11proto-xext-dev libxext-dev

4. Get the source file from here .

tar -jxvf vlc-1.0.5.tar.bz2

5. Compile then install

./configure –disable-swscale –disable-nls –disable-mozilla

If i never added –disable-nls –disable-mozilla i would of ended up with

configure: error: Buggy GNU/libc (version 2.5 - 2.7) present. VLC would crash; there is no viable work-around for this. Check with your distribution vendor on how to update the glibc run-time.

Adding the 2 above options gets me through.

make

I get this error while trying to compile
/usr/bin/ld: cannot find -lGL

So I had t make a symbolic link

cd /usr/lib

ln -s libGL.so.173.14.09 libGL.so

Then ran the make again…

sudo make install

BAM!!!! vlc 1.0.5 installed!!

Welcome home VLC …. sigh